Page tree



Skip to end of metadata
Go to start of metadata

WES 7 ver. 5.4.0

Supported Models

Supported Models are:

  • C9700 (see note below)
  • A9700 (see note below)
  • U9700 (see note below)
  • A9074 (see note below)
  • U9074 (see note below)
  • D9074 (see note below)
  • E9174
  • N9172

See the note below for installation limits of this Firmware and Service Pack.

Important Note

Disk Space Limitation

Dear Customer,

Remember that from version 5.2.0 the firmware is available and can be used only on thin clients with at least 16GB of DoM (Disk on Module) and with at least 2GB of free disk space on it.

The attempt to upgrade a device that does not meet the above conditions will produce a simple reboot of the device.

Release Notes


Issue IDTypeFromDescription
TCSETTE-503News5.4.0Citrix Receiver: version 4.9.3 LTSR is installed in the image firmware file (no SP/HF).
TCSETTE-502Improvement5.4.0Citrix HDX RealTime Media Engine is upgraded to version 2.5 in the firmware image. More information at this link https://www.citrix.it/downloads/citrix-receiver/additional-client-software/hdx-realtime-media-engine-25.html
TCSETTE-501News5.4.0VMware Horizon Client: version 4.8.0 is provided in the firmware image. More information at this link https://my.vmware.com/web/vmware/details?productId=578&downloadGroup=CART19FQ2_WIN_480
TCSETTE-500Improvement5.4.0Added Microsoft Patches: cumulative KB4284826 (for information see https://support.microsoft.com/en-ca/help/4284826/windows-7-update-kb4284826), KB4099633 (see https://support.microsoft.com/en-ca/help/4099633/security-and-quality-rollup-for-net-framework-3-5-1-4-5-2-4-6-4-6-1-4). Upgrade available at June 2018.
TCSETTE-499Improvement5.4.0Agile is upgraded to version 2.4.7 on the firmware image. (Remind that you can install Agile or update it using the specific ThinMan command).
TCSETTE-498Fix5.4.0RDP Session: if the connection is closed by the server due to user inactivity, at the next login the session crash.

Known Issues


Issue IDTypeDescription
TCSETTE-299AlertHTML5 videos are not supported using Internet Explorer 11 (e.g. YouTube videos).
Workaround: install and use Flash Player to render videos.